Welcome!

This community is for professionals and enthusiasts of the Genio platform.
Share your questions and challenges, and help your partners!

4

1
Carlos Nogueira
On 4/21/20, 2:23 PM

Hi, 

This can be related to an actual error compiling the solution (besides some miss-config regarding Vue or NodeJs).

To know for sure, you'll have to check what's being displayed on "Output" window (the error message is telling you to do) and see what's about. 

Once it has happened to me and "Output" was showing an error that cannot ran correctly using latest NodeJs version, had to rollback it to the version before, 13.9:

https://nodejs.org/dist/v13.9.0/node-v13.9.0-x64.msi


Regards,


  • Flag

Thanks all of you, Its Working Now.

i had to rollback it to the version before, 13.9 and update node-proper-lockfile (https://github.com/moxystudio/node-proper-lockfile.git)

Martins Zimba
on 4/23/20, 8:19 AM

Nice. Glad to know.

Carlos Nogueira
on 4/23/20, 8:47 AM

1
Álvaro Damas
On 4/23/20, 5:19 PM

Usually in problems with node, maybe there are problems in updating the dependencies, it is advisable to delete the one marked below, the .install-stamp file and the node_modules folder, or its contents.





0
Martins Zimba
On 4/21/20, 2:36 PM

I am working on "NightlyGenio289.30".

I tried rollback and reinstale node.js and Vue Cli, but still not working.

I think the problem is with Vue Cli Service Build

ITs NOT EXPECTED THAT GENIO CREATE IT ON GENERATION?

I get this error on Output:

2>   ERROR  Error: Cannot find module '@vue/babel-preset-app' from 'C:\QUIDGEST\GENIO_DEV\PROJECTS\SRP\GEN_SIRP\WebAdmin\Administration\ClientApp'

2>  Error: Cannot find module '@vue/babel-preset-app' from 'C:\QUIDGEST\GENIO_DEV\PROJECTS\SRP\GEN_SIRP\WebAdmin\Administration\ClientApp'

2>      at Function.module.exports [as sync] (C:\Users\quidg\Documents\Genio\PROJECTS\SRP\GEN_SIRP\WebAdmin\Administration\ClientApp\node_modules\.pnpm\registry.npmjs.org\resolve\1.14.2\node_modules\resolve\lib\sync.js:72:15)

  • Flag

My thoughts on this:

- Clean ClientApp directory (there might be old unwanted files kept there that are leading to this error); If still doesn't work, delete the client generation folder.

- I assume that you're now using Node.Js version 13.9, if not, try working with this version, im running it without any problems;

- Is any of your modules with the name empty? This should be enough to not work properly.

Carlos Nogueira
on 4/22/20, 2:22 PM

Keep Informed

About This Community

This platform is for beginners and experts willing to share their Genio knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers. Read Guidelines

Question tools

19 follower(s)

Stats

Asked: 4/21/20, 2:15 PM
Seen: 1082 times
Last updated: 8/24/20, 2:18 PM